ObjImporter smoothing issue

Aug 7, 2014 at 3:30 PM
Edited Aug 7, 2014 at 6:39 PM
Hi there!
Thanks objo a lot for your great tools!

Doesn't anybody know what can be a problem for smoothing in Helix 3D Toolkit? I have a little bit strange case.. I got an .obj file with complex 3d-model which I want to be smooth. There are 2 "s on" lines in this file. I don't remember exactly but there was some issue while smoothng - and I set currentSmoothingGroup in ObjReader always to be 1.. And that helped, part of the 3d-object is now smooth. But only part.. For example I have a 3d-model of jaw - some teeth are smooth, some - very rough - there is clear difference. Using other 3d-viewers I can see all of the teeth are smooth.

In this file there are 2 "s on" lines - one before all vertices part, another one before faces. Plus there are a lot of separated "groups" (part of vertices or faces that start with "g"). I don't know maybe that is the problem - but groups with the same names are separated all over the file - ie that can be:
g Name1
...
g Name2
...
g Name1


I also tried to change some code in ObjReader - for example in AddGroup method in the beginning I put a line
if (Groups.Any(x => x.Name == name)) { return; }
And it partially helped - all teeth were smooth, but mesh in general was a little bit broken.. Than I changed smoothingGroupMap first parametr to be not int but the name of the group - for every group to have its own smoothing map (cause in original code after adding a group smoothing maps were destroyed) - but it made everything even worse. :(

Has anybody any ideas why there can be part of 3d-model smooth, and part of it - absolutely rough?
Coordinator
Aug 8, 2014 at 11:41 AM
Does it look correct in other software? (try meshlab)
I guess there could be a bug in the obj importer. In that case we should have a small test file and create an issue on this!
Aug 8, 2014 at 1:25 PM
Yes, exactly, I tried Meshlab :) And there when I switch on "Smooth" - it becames smooth, all of the teeth.

I can send you this .obj file..
Aug 11, 2014 at 1:33 PM
Edited Aug 11, 2014 at 2:10 PM
This is how it looks:
Using HelixToolkit
Using MeshLab

I feel like there can be an issue with Groups...
Aug 11, 2014 at 2:16 PM
Edited Aug 11, 2014 at 2:19 PM
By the way, this is what happened after inserting
 if (Groups.Any(x => x.Name == name)) { return; } 
line in AddGroup method:
After

Close enough, but appeared some clearly visible trouble with a few tens triangles on a problem part of the model...
Aug 14, 2014 at 4:38 PM
Edited Aug 14, 2014 at 4:38 PM
Coordinator
Aug 18, 2014 at 12:10 PM
Thanks for providing the file! I have added the issue at https://helixtoolkit.codeplex.com/workitem/10067