Beginners Question

Mar 22, 2014 at 8:41 AM
Hi all,

I just downloaded and was trying my first program.

But I have some issues...

I have written following code
<Window x:Class="MainWindow"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:helix="http://helixtoolkit.codeplex.com"
    Title="Prova" Height="378" Width="605" 
    WindowStartupLocation="CenterScreen">
    <Grid>
        <helix:HelixView3D IsViewportHitTestVisible="True">
            <helix:HelixView3D.Camera>
                <PerspectiveCamera LookDirection="-10,-10,-10" Position="10,10,10" UpDirection="0,0,1"/>
            </helix:HelixView3D.Camera>
        </helix:HelixView3D>
    </Grid>
</Window>
But I am always getting errors stating :

__The name "HelixView3D" does not exist in the namespace "http://helixtoolkit.codeplex.com".__
__The tag 'HelixView3D' does not exist in XML namespace 'http://helixtoolkit.codeplex.com'.__
The type 'helix:HelixView3D' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built.
The attachable property 'Camera' was not found in type 'HelixView3D'.

In the project props I added a reference to HelixToolkit and alle HelixToolkit.wpf items.
I am using VS Express 2012 and have the latest Helix 3D Toolkit.

When I use the code of (Wiki Link: [discussion:459092] ) the code builds, but I still get the
__The name "HelixViewport3D" does not exist in the namespace "http://helixtoolkit.codeplex.com".__ error.

Any ideas?

Thx
Mar 25, 2014 at 10:27 AM
Hi , use this line instead :
xmlns:helix="clr-namespace:HelixToolkit.Wpf;assembly=HelixToolkit.Wpf"
Mar 26, 2014 at 6:43 AM
Hi Thanks for the response... But I did already tried that.

However I finally got it working...

First I tried the install the Nuget on VS2012 express... but that didn't work.
I downloaded the source files using the SVN link on the documentation/install page and tried to build, but I always got an error stating the helixtoolkit.csproj was not compatible with my current version.

So Uninstalled the VS2012 and installed the VS2013 express.
Still the same problem when trying to build myself...
But under VS2013 the Nuget worked. Since then I am enjoying this toolkit.

Now my code does not give me any warning or error.
Thx
Coordinator
Apr 29, 2014 at 9:45 AM
May 1, 2014 at 12:06 PM
FAQ page is empty??
Coordinator
May 5, 2014 at 1:57 PM
cache problem? The FAQ page should contain 3 questions.