manipulator scale problem ?

Jul 19, 2013 at 11:50 AM
Edited Jul 22, 2013 at 9:04 AM
Hi,
I added a .obj model and attached a combinedManipulator to it, the combined manipulator works fine but it is super small, so I scaled it using ScaleTransform3D, but then the translation became super slow, my mouse gets to the end of the screen and the model moves only really small motion. the rotation works fine though, I wonder how can I scale it correctly to have it full functioning.

Thanks
Jul 24, 2013 at 3:15 PM
Hi again, the problem is : in real life we use more sophisticated 3D models than just a cube.in the manipulator example the CombinedManipulator just fits the cube and work nicely, there is no special code there just two lines of code in the XAML to create and hook the model to the manipulator, in my 3D model the CombinedManipulator comes really really small , some times you can't even see it without zooming , after zooming it works mostly fine, scaling anyone of them to match the other just brings more problems with the manipulator, whether the translation will be useless or some times the manipulator gets detached from the model and move separately. here is my .obj model , I would appreciate it if someone can successfully attach CombinedManipulator to it.

Thanks in advance
Aug 2, 2013 at 8:41 AM
I solved it , basically I edited the library code, I bound 10% and the full value of the diameter property of the CombinedManipulator to the diameter property and the length property of the TranslationManipulator respectively, when I bind the diameter of my CombinedManipulator to the X or Y values of a BoundingBox for my model , I have a reasonable looking , fully functioning manipulator, may be objo will be interested in submitting these changes.