Materials won't load

Oct 26, 2011 at 4:49 PM

Greetings, I'm using Helix in an application to view 3d models, however, when I import the model, it's all black, with no materials. I tried several models, including the ones used on the Studio example, but the result was the same. Probably I'm doing some newbie mistake, but i would appreciate some tips to solve this.

 Here is the code that I use to load the model:

 // Fields
private TerrainCreator tc;
private Model3D CurrentModel;
private ModelVisual3D render;

public MainWindow()

this.render = new ModelVisual3D();

this.CurrentModel = ModelImporter.Load("C:\\Users\\Pedro\\Desktop\\Helix\\HelixToolkit-Examples\\StudioDemo\\Models\\Ferarri40.3ds");

this.render.Content = this.CurrentModel;
this.view.Add(render); // this is the HelixView3D


Oct 26, 2011 at 7:43 PM
Edited Oct 26, 2011 at 8:17 PM

hi Pedro! a simple question first: did you add lights to your scene? Helix toolkit has a couple of light visuals, and also a 'headlight' in the HelixViewport3D control.

Oct 31, 2011 at 3:49 PM

Problem solved. I didn't had any lights! Thanks a lot!